Introduction

Apache Configuration Editor is an application Windows 95 and Windows NT 4.0 and above. Its main purpose is to allow easier configuration of the Apache Web server.


Version History

from version | to version | Description
none | 1.X beta 1 | First incarnation
1.X beta 1 | 1.X beta 2 | Added option to set the template type from the item information tab, Updated the default config files to Apache 1.3.3, Updated the help information to Apache 1.3.3, Converted the Help format to Microsoft HTMLHelp, Complete rewrite of the installation routines, Lots of other little things....
1.X beta 2 | 1.X | First release, changed name from ApacheConfig to Apache Configuration Editor (ACE).


Installation

Installation of Apache Configuration Editor is pretty straightforward.

Step | Description
1 | Extract the ZIP file to a temporary directory. You must use a version of zip that supports long file names.
2 | Change to the directory you unzipped the archive to.
3 | Run setup.exe
4 | Read the files that are displayed and continue on until the main option screen is displayed.
5 | Select the options you desire. (See below for descriptions)
6 | Press Ok.
7 | When the completed dialog box appears you're finished!

Option | Description
Install To: | What directory to install to.
Add to Folder ( under Programs ): | What folder in the start menu to add the programs to. This is always under programs, but can be multiple sublevels down, for example you could enter: Installed Software\ApacheConfig and ApacheConfig would be installed in Programs->Installed Software->ApacheConfig from the start menu.
Add to Start Group | This will add Apache Configuration Editor to the startup group so that Apache Configuration Editor is started every time you logon.
Add Program Group | This will add a program group for the current user.
Install Uninstall Routine | This will register the Uninstall program for Control Panel.
Start after Install | This will automatically run Apaceh Configuration Editor after setup has finished.
OK | Proceed with the installation.
Cancel | About the installation.


Configuration

To configure Apache Configuration Editor, simply go to the edit menu and selection options.

This will bring up the following dialog box:

Option | Description
Confirm Delete Configuration Item | When you delete an item from the configuraiton tree, a confirmation box will appear if this is selected.
Save settings on exit | When exiting, ApacheConfig will save it's settings if this is selected.
Save current config path | This option will save the last used path when loading a configuration file if selected.
Save Window Position | This option will save the postion of the windows when ApacheConfig exits if it is selected.
Text descripition on ToolBar | This will display text on the toolbar if selected.


Using Apache Configuration Editor

Once you have Apache Configuration Editor installed and running you will be presented with the primary user interface, as follows:

There are four central areas in the window as follows:

Area | Function
Menu and ToolBar | (Top of the screen)This area contains the pull down menu and the toolbar.
Configuration Tree | (Left side of the screen)This holds the current configuration tree items.
Configuration Item Options | (Upper right of the screen)This displays the current configuration setting for the selected item.
Descripton | (Lower right of the screen)This displays the description of the currently selected item.

The Menu/ToolBar

The menu is pretty straight forward, and therefor not covered here. However one note, printing is currently not supported.

The toolbar is as follows:

from left to right, the button do the following:

New File
Open File
Save File
Use CR/LF
Quick Config
New Item
Delete Item
Exit

The 'Use CR/LF' option is used to determine if line breaks are a CR/LF or just CR. Windows uses CR/LF while Unix uses CR.

The Configuration Item Options

The configuration item option area of the screen changes depending apon what type of item is selectedl, by default the followin screen is displayed:

You can change the value in the string and then hit the update button to save the changes.

There are two other tabs to this screen, Default and Item Information.

The Default tab gives a standarized view of the configuration item:

The Item Information tab gives information about the configuration item:

The other option tabs are as follows:


Technical Information

WARNING

The following information is not for those that are feight of heart, it is assumed that you have some technical knowledge of NT/95.

The Registry

Apache Configuration Editor stores all of its configuration information in the NT/95 Registry under the following keys.

\HKEY_CURRENT_USER\Software\DarkStar\ApacheConfig

\HKEY_LOCAL_MACHINE\Software\DarkStar\ApacheConfig

The uninstall routine can be found in:

\HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\ApacheConfig

Subkeys under \HKEY_CURRENT_USER\Software\DarkStar\ApacheConfig

This key has one subkey, as follows:

Key | Description
Config | The configuration settings for this user.

Subkeys under \HKEY_LOCAL_MACHINE\Software\DarkStar\ApacheConfig

This key has several subkeys, as follows:

Key | Description
Config | The global configuration settings.
QuickConfig | The global configuration settings for the Quick Configuration options.
Templates | All configuration item details.

Values under \HKEY_*\Software\DarkStar\Launch\Config

HKEY_* refers to both HKEY_CURRENT_USER and HKEY_LOCAL_MACHINE.

These values are used to configure the program, values are used in the following order: HKEY_CURRENT_USER, HKEY_LOCAL_MACHINE, programmed default.

Programmed defaults are hard coded at compile time.
Value Name | Value Type | Default | Values | Description
ConfirmDelete | DWORD | 1 | 0 or 1 | Confirmation of deletion of items.
DefaultConfigFilePath | String | [Install Path]\Default | N/A | This is where the configuration files for QuickConfig are stored.
DefaultConfigPath | String | [Install Path]\conf | N/A | This is the default config file path.
HelpPath | String | N/A | This is where the help files can be found.
ProgramPath | String | [InstallPath] | N/A | This is where ApacheConfig is installed.
SaveConfigPath | DWORD | 1 | 0 or 1 | This is where the Save config path value from the configuration dialog is stored, 0 is unchecked and 1 is checked.
SaveOnExit | DWORD | 1 | 0 or 1 | This is where the Save Settings on Exit value from the configuration dialog is stored, 0 is unchecked and 1 is checked.
ToolBarDesc | DWORD | 1 | 0 or 1 | This is where the Text on ToolBar value from the configuration dialog is stored.
WindowDivider | DWORD | 200 | 0 to 32767 | This is where the postion of the divider bar is stored.

Values under \HKEY_LOCAL_MACHINE\Software\DarkStar\ApacheConfig\Templates

These values are a database of configuration items.

This key only contains subkeys, each subkey is the name of the configuraiton option, and from there these subkeys contain the following infotmaiton:

Value Name | Value Type | Default | Values | Description
Default | String | N/A | N/A | This is where the configuration item default value is stored, this is always a string value even for numbers.
Description | String | N/A | N/A | This is the description for the item.
Parent | DWORD | 0 | This is the number of child this item can have, for leaf items this should be 0, for group items this should be 1.
Template | DWORD | N/A | N/A | This is the template used when displaying this item. The following templates are currently defined: 117 Default Template 118 Yes/No Template 119 On/Off Template 120 Numeric Template 123 Directory Template (Unix Style) 124 Directory Template (Dos Style) 126 Information Template (Should not be used)

Values under \HKEY_LOCAL_MACHINE\Software\DarkStar\ApacheConfig\QuickConfig

This key hold the defaults for the quick configuration option, each item corresponds directly to one of the fields in the QuickConfig dialog box.


Contact Information

E-Mail DarkStar Technologies

Visit DarkStar Technologies home page